Author Topic: Baca mi error  (Read 2871 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Baca mi error
« on: April 16, 2016, 02:00:30 PM »
Takoder mi ovo baca za par razlicith plugina tipa factions ... neka ideja?


Could not pass event BlockPistonRetractEvent to Jobs v3.3.1
org.bukkit.event.EventException
   at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:305)
   at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62)
   at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.java:502)
   at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:487)
   at net.minecraft.server.v1_8_R1.BlockPiston.e(BlockPiston.java:72)
   at net.minecraft.server.v1_8_R1.BlockPiston.doPhysics(BlockPiston.java:44)
   at net.minecraft.server.v1_8_R1.World.d(World.java:583)
   at net.minecraft.server.v1_8_R1.BlockDiodeAbstract.h(BlockDiodeAbstract.java:166)
   at net.minecraft.server.v1_8_R1.BlockRepeater.remove(SourceFile:112)
   at net.minecraft.server.v1_8_R1.Chunk.a(Chunk.java:512)
   at net.minecraft.server.v1_8_R1.World.setTypeAndData(World.java:392)
   at net.minecraft.server.v1_8_R1.BlockDiodeAbstract.b(BlockDiodeAbstract.java:41)
   at net.minecraft.server.v1_8_R1.WorldServer.a(WorldServer.java:633)
   at net.minecraft.server.v1_8_R1.WorldServer.doTick(WorldServer.java:238)
   at net.minecraft.server.v1_8_R1.MinecraftServer.z(MinecraftServer.java:741)
   at net.minecraft.server.v1_8_R1.DedicatedServer.z(DedicatedServer.java:316)
   at net.minecraft.server.v1_8_R1.MinecraftServer.y(MinecraftServer.java:623)
   at net.minecraft.server.v1_8_R1.MinecraftServer.run(MinecraftServer.java:526)
   at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.NoSuchMethodError: org.bukkit.event.block.BlockPistonRetractEvent.getBlocks()Ljava/util/List;
   at com.gamingmesh.jobs.nmsUtil.v1_8.getPistonRetractBlocks(v1_8.java:21)
   at com.gamingmesh.jobs.listeners.PistonProtectionListener.OnBlockRetractMove(PistonProtectionListener.java:128)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
   at java.lang.reflect.Method.invoke(Method.java:498)
   at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:301)
   ... 18 more

Online
*
Re: Baca mi error
« Reply #1 on: April 16, 2016, 04:20:54 PM »
Probaj ugasiti plugin Jobs pa vidi da li ces imat gresku.
Ako je i dalje greska probaj ga zamijenit sa drugom verzijom ili u krajnjem slucaju sa totalno drugim jobs pluginom.

Offline
****
Re: Baca mi error
« Reply #2 on: April 17, 2016, 12:17:27 AM »
Mozes ceo log staviti?

Offline
*
Re: Baca mi error
« Reply #3 on: April 20, 2016, 08:47:18 PM »
imao sam spigot 1.8.0
sada imam 1.8.8

erori su se makli alli kako svi znamo rjesis 1 dodu 2 evo logova opet
sada baca na citizen i sentry

http://pastebin.com/6FcUH1Tz

Online
*
Re: Baca mi error
« Reply #4 on: April 21, 2016, 02:04:06 AM »
Nisam mislio da zamijenis spigot, nego Jobs plugin. xD

Ovo su greske jer pluginove koje si stavio nisu predvidjeni za verziju spigota koju koristis.
Recimo spigot trazi od plugina "EntityTeleportEvent" a plugin ga nema u sebi i ne zna sto da radi dalje, ili obrnuto ako plugin trazi nesto od spigota a spigot nema to nesto u sebi tad nece znat sta da napravi i crashat ce server ili ce samo u najboljem slucaju spremit info o gresci u log.

Trebas staviti pluginove koji su za spigot koji koristis, svaka verzija je totalno drugacija.

Offline
*
Re: Baca mi error
« Reply #5 on: April 21, 2016, 01:49:14 PM »
rjesen problem :D
obriso sam ih stavio novu verziju 1.8.8 sve radi kako treba